Emacsのhelm


Emacsにhelmというマクロがあります。helm。便利だという評判なので使ってみているのですが、使い方がいまいちよくわからない。要するに補完機能を提供してくれるマクロなのですが。

helmはまだEmacsに標準的に含まれるマクロではないので、自分でインストールする必要があります。昔なら面倒なインストール作業をしなければいけなかったのですが、現在のEmacsにはpackage管理システムがあり、helmもそれを利用してインストールできるようになっています。ですので、M-x list-packagesして、helmを選択すればいいだけなのですが、gnupackのEmacsを利用している私には一個問題が。

現時点(2014年1月)での最新版のEmacsは24.3ですが、gnupackに含まれるEmacsは一つ古い24.2です。ところが、list-packagesでインストールされる最新版のhelmはEmacs 24.3でないと対応していないようです。仕方ないので古いバージョンのhelm(1.5.0)をわざわざとってきて手動でインストールしました。



Similar Posts:

Leave a Reply

スパム防止用認証(空欄に適切な数値を記入してください)。 * Time limit is exhausted. Please reload the CAPTCHA.

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)